[IMPORTANT] Technical Update - New Rendering Engine

Today we have deployed a new rendering engine for TT2. The old one was DirectX based, while the new one is OpenGL based. This will allow us to make versions of TT2 for platforms other than Windows. First target is Mac, with distant plans for mobile some day.

Unfortunately it means that many things were changed and thus many bugs were inevitably reproduced. What we need it to EVERYONE post the following information into this thread:

  1. Which Windows version are you running
  2. Your desktop/laptop hardware
  3. Graphical / visual bugs are you experiencing after today's update. If you don't see any visual bugs - state "No bugs"

This is extremely important so please post here and ask your friends / allies to do the same.

Thanks in advance.

1 year ago

Can you explain what is meant by desktop/laptop hardware, please?

Edited by Sherriclaus 1 year ago.

1 year ago

  1. Windows 8.1 Pro
  2. HP Elite 7500 Series MT; NVIDIA GeForce GT 640;
  3. No bugs

1 year ago

Already posted there :

Windows 10 / IntelCore I7 920 2,67Ghz / 12G Ram / NVidia Geforce GTX 1060

Other thing : I went to explore a cave, and found a few twisted horns (for a chest, I suppose). There is a door that needs a key, but there is no way to get the horns - clicking on them and nothing happens (no problem with gems and other objects) and there is no chest either. No way to open the door, but I could pass using a secret way. Never had a thing like this before.

1 year ago

1.Windows 10 Home

2.Dell Inspiron 3656 - AMD A8-8600P Radeon R6 / 10 Compute Cores 4C + 6G / 1.60 GHz / 8GB RAM

3. Windows magnifier not working in game, but does elsewhere.  Also there is now a significant pause while performing tasks, ie: Click on building (pause), click upgrade button (pause), click green check mark(pause) then it upgrades.  Same for sending explorers, resources, training units, etc.

Edited by ittybittykitty 1 year ago. Reason: update

1 year ago

Windows 8.1

HP ENVY 700 PC Series/ NVIDIA GeForce GTX 645/Intel (R) Core (TM) i7-4770 CPU @ 3.40Ghz/ RAM 8GB

No bugs

Edited by Azhriaz 1 year ago. Reason: additional information

1 year ago

Reply to Sherriclaus :

Can you explain what is meant by desktop/laptop hardware, please?

Like CPU frequency, amount of ram, name of the video card, etc

1 year ago

AMD A8-7410 APU with AMD Radeon R5 Graphicas 2.2 GHz

8GB Ram - Windows 10

Cannot use full screen mode; cursor doesn't work

when switch to windowed - cursor there but cannot click on anything - changed to game cursor - this does not work either and cursor is shown as white arrow 

game unplayable

Just restarted game - can play in window mode - game cursor (although it is shown as white cursor) - full screen still no cursor

Edited by scotsgirl 1 year ago. Reason: more info

1 year ago

Windows 10

Lenovo X230 - stock hardware

No Bugs so far.

1 year ago

- Windows 7 64-bit

- Intel processor, ATI graphic card (from year 2008)

- No bugs, and actually I have a higher framerate than before, didn't know opengl could be better than directx.

I play with aero disabled (dwm.exe is running though), still when I enable it I can use windows magnifier with no issue.

1 year ago

No rendering issues currently.

Win 10 Pro 10.0.17134

Dell Optiplex 3050

Intel Core i5-7500

Memory 8GB

Display Intel HD Graphics 630 1GB memory

Edited by Fred 1 year ago.

1 year ago

windows 10 and intel core 17, 7th generation. i hope all needed info is there

button on mouse to go to desktop only works now, after i changed the game to windowed. 

button on mouse that shows me all open programs in cascade is also only working in windowed mode.

MAGNIFYING GLASS is not working at all in the game. other programs have no problems with MG.

Edited by Tsunami 1 year ago.

1 year ago

i posted it all here

1 year ago

OS: Microsoft Windows 7 Pro

Hardware: Intel NUC 6iSSY

CPU: Intel core i5

GPU: Intel Iris Graphics 540

Ram: 8GB

No bugs found so far

1 year ago

And no issue with magnifying glass on either computer.

1 year ago

Windows 10 , LENOVO Intel Core i7-4510U cant use the PM or common chat, also cant minimize or maximize 

1 year ago

AMD Phenom(tm) II X6 1090T Processor 3.20 Ghz

8.00 BG RAM

64-bit operating system, x64-based processor

Windows 10 Home  version 1803

Game was playing ok after update but, having read of the problems with the magnifier, I decided to try using it as I rely on it in the caves for finding the stalagmite tops. Big mistake lol. 

Not only didn't the magnifier work but it rendered my cursor invisible. I managed to exit the game and restarted. As I have the cursor back on the log in screen I am hoping that it will be there in the game too but please please fix the magnifier issue, thanks.

1 year ago

Lenovo windows 7 Home Premium

intel core i3-2120

cpu- 3.30 ghz


No issues so far

1 year ago

10 Home

4.00 GB

Intel ® Celeron ® J1800 @2.41

operating system, x64-based processor

no bugs 

Edited by newventure 1 year ago. Reason: spelling

1 year ago

Windows 10 64bit

Intel Core i3-6100T, 3.20GHz; 8.00 GB RAM; Intel HD Graphics 530.

So far, my only problem is when using the magnifying glass (windows feature) in which I lose my mouse in the game while in full screen mode.

Edited by River 1 year ago.

1 year ago